AppImages not working in Ubuntu MATE


#1

Hey there…

I really love the idea behind App Images, but I was never actually able to run one on my Ubuntu MATE machine…

I DO make the AppImage executable before I run it, but still nothing happens… Just sometimes the File Sytem asks me what other application I want to use to open the AppImage… But that’s it…

Am I doing something wrong?

Any ideas please?

Thank you in advance…

Cheers!


#2

Ubuntu MATE is my distro of choice and AppImages run perfectly on my machine. Have you tried starting an AppImage from the command line? That might give some debug output as to what is going wrong.

Cheers,
Chris


#3

I’m sorry, but I know absolutely nothing about the command line!

That’s why I chose MATE in the first place…

I would even know how to run from the terminal… :fearful:


#4

I am not on a Linux machine right now so I am not able to give you and detailed advice about how to do to run an AppImage from the terminal.

However from what you describe in your initial post it sounds as if you have not actually managed to make the AppImage executable. This would explain why the system is asking you what you want to use to open the AppImage. Unfortunately the best way that I know to check all this is with the terminal…

Cheers,
Chris


#5

Running flawless on Ubuntu MATE 16.04 here


#6

Well my friend, I did every thing you show in the video, and OpenShot’s AppImage still won’t open… :fearful:


#7

Thanks, but I can’t even get past the Change Directory command…


#8

OK so I finally figured a way to open the Terminal right in the folder I want it to be in, and then did the chmod thing, and now I am able to launch Krita and FontForge by double-clicking them! MOST EXCELLENT! :sunglasses:

But OpenShot still doesn’t work… :anguished:


#9

Might be an issue or missing library with the OpenShot AppImage. Please report that to the OpenShot team. Do you see any error messages when your run OpenShot from the command line?


#10

Yes, the Terminal did try to tell me something, but it was tens of lines of code, so I have no idea what is was! :expressionless:

I just sent an email to the guy behind OpenShot, maybe he’ll find a fix…

Thank you for your answers!


#11

You are welcome.

It would be best to open an Issue on the OpenShot Issue Tracker.