AppImage

AppImage can only be run from terminal on KDE

I’m generating an AppImage with Electron Builder, but I can only run it on KDE if I run it from the terminal – it just won’t start if I run it from the file browser:

The exact same AppImage works on Ubuntu though:

Any suggestions on how I could debug this? I’ve already tried capturing dolphin’s output by running it from the CLI too, but it doesn’t output anything relevant.

Edit: I’ve tested the above on Kubuntu 20.10 and Ubuntu 21.04.

Hello @relaygus, is this the case for all AppImages or just for some?

Please try Ubuntu 18.04, do you see the issue there as well?

Hi @probono! I can open it on Ubuntu with no problems indeed, so it must be related to KDE/Kubuntu. However, I can open other AppImages with no problem on KDE.

BTW, if you’d like to reproduce it, here’s the latest AppImage: https://github.com/relaycorp/awala-gateway-desktop/releases/download/v1.0.5/Awala-1.0.5.AppImage

Cheers.

I can reproduce, but it’s the same for other appimages (tried kdevelop).

Can you reproduce this on KDE neon as well?

https://neon.kde.org/download

Depending on the answer to that, it may be a KDE or Kubuntu bug and should be reported there. Thanks!