AppImage

Newer AppImages not running

I see there are already several posts on AppImages not working, which mostly seem app specific. I am having a problem with several appimages from several vendors, where older versions work fine, but the updated versions do not.

Although marked as executable, when I double click on them, nothing happens. Sometimes a tab will appear briefly in the task manager bar, then disappear with nothing else happening.

Some similar topics discuss opening the appimage from the terminal for troubleshooting. I am not sure if I am doing it correctly, as all I get with any appimage is command not found.

My system is Debian 10 Buster stable, with KDE 5.14.

Two examples of appimages I am having trouble with:

  • Station : https://getstation.com/ Version 1.43.2 works; 1.47.0 does not
  • Bitwarden: https://bitwarden.com/#download Version 1.14.0 works, but auto updates every time I run it to 1.15.2 which does not work. In both cases, alternatively downloading the newer version directly still does not work.

Also, I have tried 2 versions of Subsurface, as suggested on https://appimage.org/, neither of them worked.

Thanks,
S.

Please report the issues to the Station project, to the Bitwarden project, and to the Subsurface project.

Be sure to include the OS and version you are running, and any error messages that may appear when you try to run the AppImage from the command line.

Thanks!

We cannot help you here. We just make the tools that can be used by the Station project, the Bitwarden project, and the Subsurface project to produce AppImages. We don’t make the AppImages of those applications.