AppImage

Aborted (core dumped) when appimage is tested on newer system

I have created an Appimage project (built using Cmake) based on instructions from here: https://docs.appimage.org/packaging-guide/from-source/native-binaries.html

I have built it on Ubuntu 18.04, where it works fine (to be sure that it was portable I tested it also on linux mint 19), but on newet 20.04 ubuntu it doesn’t work.
The only thing terminal returns is:
Aborted (core dumped)

During packaging i had problem mentioned here (in case if this would be relevant):


Project I worked with:

Hi @pktiuk, welcome to AppImage.

What happens if you compile on the oldest still-supported Ubuntu LTS release, which currently is xenial (16.04) using the method described at https://github.com/probonopd/linuxdeployqt#using-linuxdeployqt-with-travis-ci? Can you upload the non-working AppImage somewhere for analysis?

Thank you very much.

I have solved this issue by myself.
It appeared that I have forgotten about plugin used by apps using QT.

1 Like