AppImage

Set appimage as default mail client

I’m trying to set up my computer, and my email is proprietary, so I cannot use any client other than the one my ESP made, if I am to use an email client at all. The thing is, my computer won’t recognize it as a mail client when I’m selecting my default applications for various uses, and I somewhat suspect it’s because it’s an appimage and not a typical application.

My current operating system is Ubuntu 18.04.4 LTS

This is the link to download the appimage in question:

https://mail.tutanota.com/desktop/tutanota-desktop-linux.AppImage

I was asking around about this here as well:

I’m hoping I have better luck here.

Hi and welcome to AppImage.

I would imagine that you need to have a desktop file for your AppImage, e.g. the optional appimaged daemon can make those for you automatically. Once your AppImage shows up in the desktop’s start menu, you should be able to set it as the default application for mail.

Let me know if this does not work.

Just integrate like @probono say , if the desktop file inside in AppImage has x-scheme-handler/mailto strings in key MimeType, the AppImage will be appear on selector, tested by modifying Leafpad text editor

Thanks for the response. I’m sorry I’m not super familiar with the terminology. Do you mean when it asks me if I would like to integrate it? If so I had done that already, and the app appeared in my start menu (I presume that’s what the dot grid in my dock is) and my settings still did not recognize it as a mail client. Since then I had removed and reinstalled it a few times experimenting with it, and it no longer appears in that menu and does not prompt me to integrate it when I open the app. I assume there are cookies or caches saved somewhere outside of the AppImage because I don’t have to log back in when I do this.

That being said, I did a little more research and came up with this:

I don’t know much about the commands in the suggested strings, so I’m having a hard time figuring out what to substitute to apply to my situation, if that would even be helpful.

When I tried to open the file in my default text editor, it made my computer almost entirely unresponsive for several minutes before coming up with a bunch of red squares and non-Latin characters which I just was not comfortable navigating.

I tried your suggestion of opening it up in Leafpad, and that was much gentler on my machine, but only displays a string of 7 characters that does not display when pasted here (aside from the letters ELF) which I have no idea what to do with. I don’t believe this AppImage has the line of code to which you are referring, but I could just be missing something.

I had all the pieces, I just needed some help putting it all together. Here’s what fixed it:

  1. Download the Tutanota Appimage (you probably already managed this, but thorough documentation is important)

  2. Install the Main Menu application by running this line of code in the Terminal application:

sudo apt-get install alacarte

  1. Find and select the Tutanota application in the Main Menu application. I found it in the left-hand list under Internet

  2. Select Properties on the right-hand side

  3. Find the Command line and add this string to the end:

MimeType=x-scheme-handler/mailto

  1. Run this line of code in the Terminal application:

update-desktop-database ~/.local/share/applications

At this point the Tutanota app should display as the default mail app if you check out settings.