Problem with desktopintegration


#1

Hi,

I am trying to add desktop integration to my AppImage (on CentOS 7), but not matter what I try the dialog which asks for integration doesn’t show up (I tried the subsurface demo and with that the dialog appears, so must be something I am doing wrong).

Perhaps someone has an idea what I am doing wrong?

I have the desktopintegration script in ./usr/bin/ThePawn.wrapper
(with x-rights for all)

In the file ./ThePawn.desktop I have the following lines:
[Desktop Entry]
Type=Application
Name=ThePawn
Exec=ThePawn.wrapper
Icon=Pawn
Comment=The Pawn Remastered
Terminal=true
MimeType=application/x-brahman
Categories=Game;
X-KDE-NativeMimeType=application/x-brahman

Additionally I have the following icon files in the appdir:
./pawn.png
./usr/share/icons/default/128x128/apps/pawn.png
./usr/share/icons/default/128x128/mimetypes/application-x-brahman.png
./usr/share/icons/default/256x256/apps/pawn.png
./usr/share/icons/default/256x256/mimetypes/application-x-brahman.png

The app itself works perfectly. It just gets started without asking for desktop integration. Perhaps I should add that it is a Qt 5.8 application and the AppImage is ctreated with linuxdeployqt. Not sure if it matters.

Any help is highly appreciated!
Thanks!


#2

AppImages created with linuxdeployqt directly launch the application and ignore the desktop file since AppRun is a symlink, rather than an executable that parses the desktop file.

I can post a procedure for how to change this manually if you really need it.

Otherwise I recommend to use the appimaged daemon which can integrate AppImages into the desktop automatically for you.


#3

Hi,
yes, would be great if you can guide me on how to change this. appimaged is a very nice tool, but it would require to be installed on the target machines. So it would be great to have an option without the daemon.
Thanks!


#4

Can you please send me a link to your ThePawn.AppImage so that I can fix it?
Thanks.


#5

Thanks a lot for your offer. Meanwhile I fixed this by myself after your hint at the symlink. I replaced the symlink with a real AppRun app and rearranged some of the files (qml and the qt plugins into usr/bin). Seems to work now!