AppImage

Pkg2appimage fails to download package gir1.2-gspell-1, gir1.2-gst-plugins-base-1.0

I’m trying to build appimage of gajim, but among the packages two of them are not being installed because of unsatisfied dependency. Here is a small demo:

gajim.yml

app: gajim

ingredients:
  dist: focal
  sources: 
    - deb http://us.archive.ubuntu.com/ubuntu focal main universe multiverse restricted
    - deb http://us.archive.ubuntu.com/ubuntu/ focal-updates main universe multiverse restricted

  packages:
    - gir1.2-gspell-1
    - gir1.2-gst-plugins-base-1.0

when I try to build this recipe I get the following errors:

libegl-mesa0:amd64 Depends on libgbm1:amd64 < 9:999.999.999 @ii mK > (= 20.0.4-2ubuntu1) can't be satisfied!
gir1.2-pango-1.0:amd64 Depends on libpango-1.0-0:amd64 < 9:999.999.999 @ii mK > (= 1.44.7-2ubuntu4) can't be satisfied!

I’ve checked the forum and the appimage wiki. I don’t know how to solve this issue.

Hi @commandos, you will need to use the pretend key to pretend that the exact versions of those two libraries are installed.

Even better though, ask the Gaijm developers to provide an official AppImage for download.