AppImage

Trying to run ICIJ neo4j AppImage


#1

Hi! On Oracle Linux Server (similar to Centos/RHEL 6) I am trying to run the ICIJ Offshore Leaks neo4j AppImage (download link). The image has the name neo4j-desktop-for-icij-1.0.0-x86_64.AppImage.

After making the file executable and issuing

./neo4j-desktop-for-icij-1.0.0-x86_64.AppImage

I get the following error:

fuse: failed to exec fusermount: Permission denied

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
See https://github.com/AppImage/AppImageKit/wiki/FUSE 
for more information
open dir error: No such file or directory

The AppImage seems to need an external FUSE pacakge? I then ran

./neo4j-desktop-for-icij-1.0.0-x86_64.AppImage --appimage-extract

and this indeed extracted the content (to a sub directory squashfs-root). But how do I start the app now? I tried

./squashfs-root/AppRun

but this gives me

Desktop file is missing. Please run ./squashfs-root/AppRun from within an AppImage.

So how do I do this how do I start the app?

Thanks for any pointers!


#2

Yes, as is described in the message and the link provided therein, https://github.com/AppImage/AppImageKit/wiki/FUSE.

This is correct.

This appears to be a bug in neo4j-desktop-for-icij-1.0.0-x86_64.AppImage. Please report it to the author of that AppImage.

As a workaround, you may want to edit ./squashfs-root/*.desktop and change the line that starts with Exec=; remove the .wrapper extension if you see one. (I did not have a chance to look at the extracted AppImage yet; so please let me know if this worked.)