AppImage

Every Appimage I try ends with "execv error: No such file or directory" with firejail on Manjaro, Wayland and Gnome


#1

Hi there,

I am new to appimages and firejail and I need some help to get started. So far I tried to run the appimages of Nextcloud, Cryptomator and RawTherapee in a firejail started with:

firejail --appimage --trace

When I try to run the appimage it ends with
“execv error: No such file or directory”

I am running Manjaro 18, with Wayland and Gnome. Any help is highly appreciated.

Cheers,
Paul


#2

Hi Paul, welcome to AppImage. What happens if you run the same AppImages without Firejail? If you don’t want to do this on your real system, you can use a Live ISO of your distribution to try it out.


#3

Hi, I tried all the Appimage without firejail on my machine and they worked. As in their GUI showed up, which it does not when running inside a firejail. Once integrated the only appimage that shows the same error is the one from Cryptomator. The other two just crash with a segfault, maybe because of missing permissions, but as far es I can tell, they can access the files that are printed in the trace.

Two questions remain:

  1. How can I integrate appimage while running them inside a firefjail?
  2. How do I find out which permissions are needed to run the appimage?

Many thanks,
Paul

Last few lines from the integrated Nextcloud appimage ran in firejail:
75:Nextcloud-2.5.0:open64 /usr/bin/../share/appimagelauncher/l10n/desktopfiles.fr.json:17
75:Nextcloud-2.5.0:open64 /usr/bin/../share/appimagelauncher/l10n/desktopfiles.de.json:17
75:Nextcloud-2.5.0:open64 /usr/bin/../share/appimagelauncher/l10n/desktopfiles.en.json:17
75:Nextcloud-2.5.0:open64 /home/paul/.local/share/applications/appimagekit_bbf446e68460704258662257c773fb18-nextcloud.desktop.QZGUSZ:-1
Segmentation fault (core dumped)

#4

appimaged will use Firejail if it is installed on the system. Uninstall Firejail and log into your desktop again, then the AppImages should be integrated withotu Firejail.

Please report any issues with Firejail concerning AppImages directly to https://github.com/netblue30/firejail/issues, thanks.