Running AppImage app on Ubuntu 16.04


#1

Hello. I need to run my AppImage app using command line. At first i make it executable using chmod a+x *.AppImage. It works. But when i’m trying to launch it i’ve got this message:
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the ‘nonempty’ mount option

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See https://github.com/probonopd/AppImageKit/wiki/FUSE
for more information
open dir error: No such file or directory

OK I’m trying --appimage-extract option it works for just ten mins and ends with
fopen error
decompressed just 1GB when my AppImage is 14GB.

Please help me. Tell me how to mount AppImage using command line. Or please tell me why my --appimage-extract decompress ends with fopen error. Thank you.


#2

You have a 14 GB AppImage? Interesting. Never tried one that is so large.

Does it work if you use e.g. a Ubuntu Live ISO?


#3

Yes i had. dowloaded it here

https://rutracker.org/forum/viewtopic.php?t=5355039

Thank you for reply but i don’t need help any more because this problem solved by installing windows and downloaded game from another source


#4

I suspect your download was corrupt.


#5

You know you made it big when AppImage is used for warez. Congrats @probono :wink:


#6

My friend software developer told me that my appimage-extract option ends with
fopen error
because AppImage ran out of limit file descriptors


#7

My friend software developer told me that my appimage-extract option ends with fopen error because AppImage ran out of limit file descriptors

In this case, you could try to loop-mount the AppImage and copy out its contents. If it is a type 2 AppImage, then --appimage-offset to get the offset in bytes, then mount with the -o option.

Of course, pull requests would be welcome.


#8

Please run

ulimit -n 10000

Then try to extract the AppImage again. Does it solve the problem?


#9

I ran

ulimit -n 10000

Nothing changes. The same extract stop point with fopen error.


#10

It’s very difficult for me. If you type the code that i must try i will.


#11
./Civilization_VI-1.0.0.56-x86_64.AppImage --appimage-offset
123456 # You will see another number

# Use the number you got above instead of the example 123456
sudo mount ./Civilization_VI-1.0.0.56-x86_64.AppImage /mnt -o loop,offset=123456

sudo cp -r /mnt ./Civilization_VI-1.0.0.56-x86_64.AppDir
sudo chown -R $USER  ./Civilization_VI-1.0.0.56-x86_64.AppDir
./Civilization_VI-1.0.0.56-x86_64.AppDir/AppRun

#12

instead of it I’ve got
denis@denis-Inspiron-1520:~/Загрузки$ qemu-x86_64 ./civ6.AppImage --appimage-extract
warning: TCG doesn’t support requested feature: CPUID.01H:ECX.vmx [bit 5]
trv.path: .DirIcon

I also use qemu to extract it as you see the x86_64 AppImage on i386 machine (add architecture was successfully added before).

Snapshot also available
http ://savepic.ru/ 14296311.png (please delete spaces)
Can you please see it and help me.


#13

Sorry I made a mistake, instead of --appimage-extract you need to use --appimage-offset. Corrected above.


#15

now AppImage successfully extracted in civ6.AppDir. size folder=19.3G. when AppImage=13.3G
but whein i’m trying to run it
using
./Civ6.AppDir/AppRun
i’ve got
msg
./Civ6: 1: ./Civ6: Syntax error: word unexpected (expecting “)”)


#16

Please post your AppRun file.


#17
#!/bin/sh
HERE="$(dirname "$(readlink -f "${0}")")"
export PATH="${HERE}:${HERE}"/usr/bin/:"${HERE}"/usr/sbin/:"${HERE}"/usr/games/:"${HERE}"/bin/:"${HERE}"/sbin/:"${PATH}"
#export LD_LIBRARY_PATH="${HERE}"/usr/lib/:"${HERE}"/usr/lib/i386-linux-gnu/:"${HERE}"/usr/lib/x86_64-linux-gnu/:"${HERE}"/usr/lib32/:"${HERE}"/usr/lib64/:"${HERE}"/lib/:"${HERE}"/lib/i386-linux-gnu/:"${HERE}"/lib/x86_64-linux-gnu/:"${HERE}"/lib32/:"${HERE}"/lib64/:"${LD_LIBRARY_PATH}"
#export PYTHONPATH="${HERE}"/usr/share/pyshared/:"${PYTHONPATH}"
#export XDG_DATA_DIRS="${HERE}"/usr/share/:"${XDG_DATA_DIRS}"
#export PERLLIB="${HERE}"/usr/share/perl5/:"${HERE}"/usr/lib/perl5/:"${PERLLIB}"
#export GSETTINGS_SCHEMA_DIR="${HERE}"/usr/share/glib-2.0/schemas/:"${GSETTINGS_SCHEMA_DIR}"
#export QT_PLUGIN_PATH="${HERE}"/usr/lib/qt4/plugins/:"${HERE}"/usr/lib/i386-linux-gnu/qt4/plugins/:"${HERE}"/usr/lib/x86_64-linux-gnu/qt4/plugins/:"${HERE}"/usr/lib32/qt4/plugins/:"${HERE}"/usr/lib64/qt4/plugins/:"${HERE}"/usr/lib/qt5/plugins/:"${HERE}"/usr/lib/i386-linux-gnu/qt5/plugins/:"${HERE}"/usr/lib/x86_64-linux-gnu/qt5/plugins/:"${HERE}"/usr/lib32/qt5/plugins/:"${HERE}"/usr/lib64/qt5/plugins/:"${QT_PLUGIN_PATH}"
EXEC=$(grep -e '^Exec=.*' "${HERE}"/*.desktop | head -n 1 | cut -d "=" -f 2 | cut -d " " -f 1)
cd "$HERE"
exec "${EXEC}" $@

#18

can not upload as file because of allowed extension

when i try to add allowed extension i’ve got error

Sorry, but we couldn’t determine the size of the image. Maybe your image is corrupted?


#19

Please change #!/bin/sh to #!/bin/bash and try again.


#20

nothing changes


#21

i test my script on online services
both of them told me that error in line 12
i change
exec “${EXEC}” $@
to
exec -a “${EXEC}” $@

as result no errors but nothing happens

snapshot