AppImage

Cannot mount AppImage, please check your FUSE

As far as I know, running AppImages is just making the AppImage file executable in linux and the app will run.

I am using Debian Stretch 9.
Desktop is gnome desktop or the default Debian 9 desktop
AppImages are:

  • List item
  • BeeKeeper Studio
  • LibreOffice fresh
  • AppImageLauncher lite 2.2.0 → I tried to use this so that I can add desktop launcher for my appimages

I tried to run appimagelauncher lite but it didn’t work???!?!?! I just saw an AppImageLauncher Desktop Icon but clicking it doesn’t seem to do anything.

As far as I know I’m just happy I can click the BeeKeeper Studio and LibreOffice AppImages and it runs as expected.

The annoying problem is – after a while (usually after I unlock the desktop to use the computer again) I receive countless Cannot mount AppImage, please check FUSE…notification. I go to the link provided and did the instructions to install FUSE. I still get the annoying notification.

Please help troubleshoot. I am a heavy desktop user and has some knowledge about command line in linux but not at expert.

Thanks,

Ben

So the Beekeeper Studio AppImage normally works? If possible, replace AppImage Launcher Lite with the full AppImage Launcher. It looks like it seems to be more preferred.

The FUSE error happens if you don’t have FUSE (very unlikely on modern Linux distros) or if thousands of AppImages are mounted at the same time (which could be caused from a bug in a specific AppImage)

Does restarting your computer temporarily fix the issue? If so, then it’s probably an AppImage recursively running itself. In that situation you should try sending a bug report to the developers of whatever AppImage you’re using

Thanks for replying especially a sensible enough reply to me.

I know I have fuse installed and followed the instruction in the link from the notification to set up fuse.

Restarting fix the issue. I suspect that when the desktop wakes up from screen saver mode, the annoying constant notifications appear. Also in some session, I did not particularly run any AppImage Apps so in my understanding there should be no notification, but it still has.

I used synaptic to purge appimage launcher or what looks like appimage launcher from the list of searched apps. No luck.

I’ll try to report a bug… :frowning_face:

I’m not exactly sure what causes it, but I had a similar problem with appimaged, which is why now I don’t use any kind of daemonized AppImage management anymore. I really don’t even know if it’s a problem with the project itself, or something else.

Although, I’m working on a small project which should be able to manage AppImages relatively well without a daemon, but it still has a bit of tweaking to do. I want it to be very user-friendly and intuitive to use

Please ask over at Issues · TheAssassin/AppImageLauncher · GitHub because its developer doesn’t read here. Thanks!