AppImage

Failing to extract and repack OpenShot


#1

I’m trying to run OpenShot AppImage on Porteus 4.0 Xfce distro, but there’s an error that I guess it’s related to freetype2 lib:

/tmp/.mount_g0Iots/usr/bin/launch: symbol lookup error: /usr/lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

I decided to unpack it using P7zip, update freetype2 and then repack it using appimagetool (ARCH=x86_64 appimagetool [folder]), but when I try to execute it I receive the following error:

execv error: Permission denied

So I tried to simply unpack and repack without touching any file (except for chmod a+x the AppRun file), and I get the same error. What am I missing?

One more question: why people don’t use TinyCore distro as the testing system? I’m asking this not because I use TinyCore, but because it’s the most basic distro I know and if an AppImage runs there it will probably run anywhere. It’s very common to see an AppImage that runs on Ubuntu family and fails to run outside it. :frowning:


#2

IPlease inform the author of the application about the issue and ask them to provide a fixed AppImage.


#3

@probono, thanks for the reply. Any idea why I can’t unpack and repack successfully even without touching anything?


#4

Probably p7zip cannot really handle AppImage. I guess it discards the permissions when extracting.


#5

It makes sense :slight_smile: Any idea of how to properly extract an AppImage that doesn’t run?


#6

It’s hard to believe that this cannot be found out. Where have you looked for this information before asking? In any case:

Mount with

wget "https://github.com/OpenShot/openshot-qt/releases/download/v2.4.3/OpenShot-v2.4.3-x86_64.AppImage"
chmod +x OpenShot-v2.4.3-x86_64.AppImage
sudo mount OpenShot-v2.4.3-x86_64.AppImage /mnt -oloop,ro

Repack with

wget "https://github.com/AppImage/AppImageKit/releases/download/continuous/appimagetool-x86_64.AppImage"
chmod +x appimagetool-x86_64.AppImage
./appimagetool-x86_64.AppImage /mnt

As a side effect, you now have a type-2 AppImage which can do neat tricks:

./OpenShot_Video_Editor-x86_64.AppImage --appimage-help
AppImage options:

  --appimage-extract [<pattern>]  Extract content from embedded filesystem image
                                  If pattern is passed, only extract matching files
  --appimage-help                 Print this help
  --appimage-mount                Mount embedded filesystem image and print
                                  mount point and wait for kill with Ctrl-C
  --appimage-offset               Print byte offset to start of embedded
                                  filesystem image
  --appimage-portable-home        Create a portable home folder to use as $HOME
  --appimage-portable-config      Create a portable config folder to use as
                                  $XDG_CONFIG_HOME
  --appimage-signature            Print digital signature embedded in AppImage
  --appimage-updateinfo[rmation]  Print update info embedded in AppImage
  --appimage-version              Print version of AppImageKit

Portable home:

  If you would like the application contained inside this AppImage to store its
  data alongside this AppImage rather than in your home directory, then you can
  place a directory named

  /home/me/OpenShot_Video_Editor-x86_64.AppImage.home

  Or you can invoke this AppImage with the --appimage-portable-home option,
  which will create this directory for you. As long as the directory exists
  and is neither moved nor renamed, the application contained inside this
  AppImage to store its data in this directory rather than in your home
  directory

#7

But anyhow, please explain the OpenShot authors what the problem is and ask them to provide a fixed AppImage. End users should not have to fiddle around like this. The AppImage is apparently broken.


#8

Thanks for helping me. So I did the following inside a sudo terminal:

wget "https://github.com/AppImage/AppImageKit/releases/download/continuous/appimagetool-x86_64.AppImage"
mkdir 2
sudo mount ./OpenShot-v2.4.3-x86_64.AppImage ./2 -oloop,ro
ARCH=x86_64 ./appimagetool-x86_64.AppImage ./2
chmod +x ./OpenShot_Video_Editor-x86_64.AppImage

And finally:

./OpenShot_Video_Editor-x86_64.AppImage

Unfortunately I get the following error:

execv error: Exec format error


#9

Are you sure you are on a x86_64 machine?

If yes, then please report this issue to the OpenShot team.


#10

Yes, I’m 100% sure. I’m one of the Porteus distro developer. :slight_smile:

I think we’re missing something here. It’s not a problem with OpenShot package itself since it originally doesn’t show this ‘Exec format error’, only after unpacking and repacking it. The problem seems to be related to the way we’re unpacking/repacking.

Thanks


#11

Please report the issue to the OpenShot team and ask for a fixed AppImage so that you don’t have to unpack and repack it.