AppImage

Opensuse Leap 42.2 .AppImage Applications Will Not Run


#1

Hello, I have been trying to get Etcher installed on my laptop running opensuse with KDE. I have made my file executable, and tried running it in the terminal. The app will not run, bash says permissions denied, this holds true even when run as root.

I have since tried running different programs in .AppImage formats. None have worked, all the same error.

When run in Dolphin, the app opens in K3B. I have tried running the same files from a Fedora live disk, and the files run as expected.

I have searched the web trying to find a solution, and I have yet to find anyone with any problems beyond the file was not made executable. Please, any help would be greatly appreciated.


#2

Please try running the AppImage from the command line and paste any error messages here.


#3

I ran an ls to show the file was indeed executable, and ran it both as myself and as root (using sudo).

nick@linux-laptop:~/Downloads/Etcher-1.0.0-linux-x64> ls -l
total 68352
-rwxr-xr-x 1 nick users 69992448 May 12 01:17 Etcher-1.0.0-linux-x64.AppImage
nick@linux-laptop:~/Downloads/Etcher-1.0.0-linux-x64> ./Etcher-1.0.0-linux-x64.AppImage
bash: ./Etcher-1.0.0-linux-x64.AppImage: Permission denied
nick@linux-laptop:~/Downloads/Etcher-1.0.0-linux-x64> sudo !!
sudo ./Etcher-1.0.0-linux-x64.AppImage
root’s password:
sudo: unable to execute ./Etcher-1.0.0-linux-x64.AppImage: Permission denied


#4

If you havn’t solved this, perhaps check if Downloads is mounted with noexec. Does the problem only occur with AppImages or can’t you execute at all in Downloads? Should work actually. I have a standard Leap 42.2 desktop install and it runs AppImages just fine, also from Downloads folder.


#5

Please run as root:

chmod a+x /usr/bin/fusermount
chown root /usr/bin/fusermount
chmod u+s /usr/bin/fusermount

Then try running the AppImage again, as a normal user. Does it work?


#6

Turns out to be a Tumbleweed bug:
https://bugzilla.suse.com/show_bug.cgi?id=1041159