AppImage

Running the second executable causes libcurl warning

Hi,

I use AppImage for bundling my app. There is a main executable which runs pretty fine and without issues. But when it has a crash, I use Google Breakpad to catch that crash. And to upload minidump of the crash on the web site, I run another one executable from the bundle (called minidump_upload). I put it in the same directory as the main executable. And when I run minidump_upload by std::system() call from the main program, I have a warning:
Failed to open curl lib from binary, use libcurl.so instead
and everything works well and the minidump_upload runs correctly and uploads everything on the website.

My linuxdeployqt command to budle looks like this:
linuxdeployqt AppDir/usr/share/applications/neutrino-editor.desktop --appimage-extract-and-run -appimage -bundle-non-qt-libs -extra-plugins=imageformats/libqjpeg.so -qmake=$QT5_DIR/../../../bin/qmake

Did I miss something? Do I need somehow to specify minidum_upload executable for linuxdeployqt?
And finally, should I worry about such warning?

Thanks.

I found that the executable produces the same warning even outside of the bundle. So, apparently it’s not a problem of AppImage.

You may need to bundle the dependencies of minidump_upload as well, like this:

linuxdeployqt AppDir/usr/share/applications/neutrino-editor.desktop --appimage-extract-and-run -appimage -bundle-non-qt-libs -extra-plugins=imageformats/libqjpeg.so -qmake=$QT5_DIR/../../../bin/qmake -executable=AppDir/usr/bin/minidump_upload