AppImage

Adding my .SO file to the bundle

Hello,

I’m using Ubuntu 18.04 and using linuxdeployqt-7-x86_64 with “-unsupported-allow-new-glibc -appimage”.
I’ve successfully created my app image using test gui I made using Qt, and now trying to create my actual app which contains my *.so file, I’ve tried following the guide how to use it, and when I generate the appimage I’m not getting any issues, but when trying to run my appimage, I’m getting error saying my .so.
The error is:
“error while loading shared libraries: libfnc_so2.so: cannot open shared object file: No such file or directory”

I’ve copied the *.so file both to the direction I’ve used to create the appimage with and next to the appimage itself, still receiving the error.

The .so is linked to the Qt itself and using the framework I’m having to issues running my app there.

Have I tried to include the .so wrongly?

Issue has been resolved.

I’ve created configure file over /etc/ld.so.conf.d which contains only a single line of text which is the directory of my “missing” .so.
Afterwards I’ve ran ldconfig and problem was resolved.

Hi @royraihen, welcome to AppImage.

Please do not use unsupported flags. They are, well, unsupported, and in most case break the resulting AppImage.

When using linuxdeployqt, please build on the oldest still-supported operating system release as shown in https://github.com/probonopd/linuxdeployqt#using-linuxdeployqt-with-travis-ci. Otherwise your generated AppImages will almost certainly not run on all still-supported Ubuntu releases and similar “old” operating systems.