AppImage

Please help 32bit "dino"

Hello,

I am a newbie in Qt and Linux just wondering how people ever deployed own written applications out of the IDE to another PC, if its THAT complicate still mission impossible. (I am Windows user - sorry. And yes I still use 32bit Hardware/Software - very seldom 64bit but more often than 16bit :slight_smile:

I managed to use your great linuxdeployqt (without any appimage - I rather make simple apps) in a 64bit Linux Mint 19.2 (Qt 5.13.2, g++ 7.30 as I remember).
But NOT on 32bit Linux Mint 19. I only found Qt Creator 5.5, g++ dont know?
I downloaded your source and compiled with the IDE. Program start: Tells me about my any GLBC library is too new. So what can I do???
Change Qt? Which version? Change g++ From where (I simply installed by apt-get). Change whole Linux Mint? Which version?
Do you know any help???
I just had the idea to search for the error-message :slight_smile: but sorry I am a newbie.
I also could build a similar Folder-structure and a program.sh as in the proposal. BUT unfortunately linuxdeploy seems to not only copy the .SO but also changes in size?! Hey thats too hard for a newbie!
Cannot I copy the versions provided by the Qt/gcc folders?

To make clear - I dont build complicate Apps - simple console oder gui only. And as I am a windows
people, I am not interested in 100 ways to deploy or the best excellent way to do.
But NO WAY deploy??? Really?

Thanks in advance and sorry for my Englisch

Hi, please build your application on the oldest stil-supported Ubuntu LTS release, which is xenial at this time.

If you try to build on a system that is newer than it (e.g., Linux Mint 19.2) then the binaries compiled there will not be able to run on all still-supported releases of Ubuntu. linuxdeployqt refuses to run in this situation, so that application developers build on a distribution not newer than the oldest stil-supported Ubuntu LTS release, for best compatibility of your binaries.

If you don’t want to change the distribution on your local machine, you can use a cloud-based build service like Travis CI as described in the linuxdeployqt readme.

For a new user of linuxdeployqt, it’s best to follow the .travis.yml example 1:1 from the readme.

@probono Thanks for your help. After 100 tries I finally managed to compile linuxdeployqt in 32/64bit Linux Mint. Hard job for a beginner…

But - I know you dislike reading - I didnt gone the next step to build an appimage. Too complicate for me and again problem that it couldnt run on all target systems.

So I use now another deploy: cdeployqt :slight_smile: I installed in Mint 64bit but didnt work for 32bit. NO WAY. Neighter InstalI nor compile. I am too stupid or Linux is paranoid, I tried 4 source code versions.
And 32bit is not favoured by Linux people (I am Windows people and I love 32/16bit).

BUT I analyzed the output of cqtdeployer (a structure of folders with the needed libraries and finally a shell-script) and I could adopt it for another simple application. And for some of the qt-examples, all worked - I only added 3 more .SO (all for 64 bit).

THEN I made a similar structure for 32bit and collected the needed .SO
So far it worked. I seen my applications on Mint 17, 18, 19, Ubuntu Mate (64bit) and on Mint 18, 19 and Debian (32bit). So its prove enough for me it works.

I packed all with 7zip so it becomes in fact a portable application to can run anywhere.
AND for me as a Windows-User it’s logical solution and similar to that what many applications do there: bring along their own runtimes (.SO)

Probably there are 1000 more efficient and clever solutions to deploy - but nobody even told me any one working. And my Linux dont let me copy even my own files… forbidden, forbidden, forbidden… :slight_smile:

So Thanks for your help. I have a beginners deploy now. May be I will return a see back to appimage when I am more experienced. For now and my applications level its enough