AppImage

Does my / this distro support AppImage?

Hi, I’m Phil ; I’ve been using AppImages for years now (mainly in Debian stable) specially in the music app sphere, where bleding edge apps are seldom packaged, a good example being QTractor, my sequencer of choice.
I tried a lot of other “self-contained linux executable” formats, namely snap and flatpak, but none worked for me, AppImage does.

Now ; I’m on this machine (that happens to be a raspberry pi 4, but it’s not really the point, more later) and I can’t get AppImage to work :

chmod +x my.AppImage
./my.AppImage
bash : ./my.AppImage: No such file or directory

So I’d like to take this from the start :

  • How do I check for AppImage Capabilities on a given Distro ?
  • Is there a list of very simple (like not subsurface or some huge framework) apps in AppImage format for testing?

Ideally, I’d love a command / script that would output :

  • Yes, this OS can run AppImages in this format : aarch64 GNU/Linux or
  • No, this OS cannot run AppImages because those libs are missing : x, y, etc.

Is this possible?

Unfortunately, not many AppImages are available for this architecture yet.

I general, AppImages can run if there is FUSE set up correctly on the system. To test this, just try running an AppImage from Release Continuous build · AppImage/AppImageKit · GitHub.

Whether a specific AppImage runs on that system, however, depends on what the author of that particular AppImage has put inside the AppImage.

We test to make sure that the AppImages on https://appimage.github.io/ work on the oldest still-supported Ubuntu LTS release on x86_64.

1 Like

Thank you very much for your answer (and for AppImage) ; I’ll investigate further if I can run this on an Arm machine.

On a not totally unrelated note, I needed to write in a config file inside of an AppImage executable, and found the extract / edit / rebuild procedure a real joy! Man, AppImage is a thing of functional beauty.