AppImage

Creating an AppImage on Ubuntu 12.04

Hi,

I know that the preferred method to create appimages is to use travis, and that targeting the oldest LTS Ubuntu is the preferred method. But I would like to make an AppImage on Precise - Ubuntu 12.04. The reason is that the codebase doesn’t seem to compile on any higher LTS. (The codebase is here, https://github.com/pdbourke/vlc-warp-2.1
and my experience with building it is here,
https://hnsws.blogspot.com/2013/12/compiling-vlc-warp-from-git.html
)

Just now, I tried building it again on a VM - worked.
Then tried making an AppImage with the same sequence of steps as in the example travis script. But linuxdeployqt-continuous-x86_64.AppImage complained that libraries are too old.

Then I tried the oldest existing linuxdeployqt release (5). That also complained the same thing.

Then I tried compiling the earlier release of linuxdeployqt (4) from source. In the build instructions, it was recommended to use QT Creator appimage 5.7.0 from
https://bintray.com/probono/AppImages/QtCreator#files

But that QtCreator-5.7.0-x86_64.AppImage also complained that libraries are too old!

So, my questions are:

  1. Should I try to go ahead and install QT creator from ubuntu’s repos, and then try to build the linuxdeployqt project ? Would that work?

  2. Is there any way in which I can bundle all required depencies, either using linuxdeployqt or manually? Maybe using ldd ?

  3. Or is this whole project not feasible at all?

(Sorry if this is already covered somewhere, just couldn’t find anything current.)

Hi,

Replying to my own question.

Finally got an AppImage created with linuxdeployqt by

  1. upgrading gcc on 12.04
    https://stackoverflow.com/questions/22925717/adding-qmake-cxxflags-std-c11-to-pro-file-in-qt-not-workingon-linux-12-0
    https://stackoverflow.com/questions/19836858/upgrade-gcc-4-6-3-on-ubuntu-12-04-to-4-8-2

  2. installing QT5
    https://askubuntu.com/questions/279421/how-can-i-install-qt-5-x-on-12-04-lts

  3. copying some libs to a directory and adding this export LD_LIBRARY_PATH
    https://github.com/probonopd/linuxdeployqt/issues/105

linuxdeployqt said success. Created an AppImage file.

But when I try to run the AppImage file on another machine (newer environment, Linux Mint 18.3) it does not find some of the required files -

./VLCWarp*AppImage
VLC media player 2.1.1 Rincewind (revision 26d1986)
[0x25f03e8] main libvlc error: No plugins found! Check your VLC installation.

Any pointers would be welcome.

( I see that there is a vlc appimage created using a very different set of tools,


Is that the only way I can create a working appimage for VLC-based players?)

I tried copying over the directories modules po share extra etc also manually into the appdir/usr/bin directory before running
linuxdeployqt aapdir/usr/share/applications/*.desktop -appimage

That resulted in a 100 MB AppImage (versus the 970 kB appimage earlier) but still gave the same error if I try to run it.

It runs fine on the machine used to build it. But on another machine, it fails with
[0x7793e8] main libvlc error: No plugins found! Check your VLC installation.

Any help would be much appreciated.

Also tried the exporting of VLC_PLUGIN_PATH
as suggested here,

That also did not help.

I see that probono himself had trouble with packaging vlc as an appimage!
https://mailman.videolan.org/pipermail/vlc-devel/2016-May/107690.html

So I suppose it would be foolish of me to try.

I will try to compile a windows version and run it under wine instead.