AppImage

AppImage starting separate process

After creating an AppImage for The Powder Toy, I noticed that it annoyingly doesn’t stack the new icon on top of the AppImage in the launcher itself. I can tell it isn’t a Gnome issue because AppImages like LibreWolf and Krita display properly in the dock. What is the proper way of building one in order to make it display the icon properly? I’ve even tried dissecting the AppRun of LibreWolf and I can’t see any differences besides the program they’re launching.

First picture is expected behavior using LibreWolf as an example, 2nd is what’s happening when I click the icon.

Screenshot from 2021-02-14 21-04-42
Screenshot from 2021-02-14 20-53-44

Possibly you need to set StartupWMClass in the desktop file?

That worked! Thank you so much

For anyone else having the same problem, run xprop | grep CLASS and click on the running program of the AppImage you’re trying to create. Use the output of that command as the class under StartupWMClass in the desktop file.