Appimage administration

Hi there,

My OS is linux and I want to extract one single file in an existing AppImage, replace it and reassemble the changed AppImage. I downloaded latest release dated Dec 31, 2020 from Releases · AppImage/AppImageKit · GitHub

Following instructions at AppImage user guide, the containing files of the relevant AppImage could be perfectly listed in terminal with the command

$ ./appimagetool-x86_64.AppImage --list ./NAME_OF_FILE.AppImage

Then I’ve tried to extract the AppImage with

‘$ ./appimagetool-x86_64.AppImage --appimage-extract ./NAME_OF_FILE.AppImage’

Result is a new folder squashfs-root is created.
But folder is empty no files were extracted. No error message returned. :frowning:

What went wrong? Is this a bug?

Possibly a bug, yes.

Which file exactly do you want to extract from appimagetool-x86_64.AppImage?

I have tried to extract a FC AppImage.

Please follow this link:

Does it work when you leave away the . in ./? Or leave away the whole ./?