AppImage

Wings3d x64 appimage creation

I have been trying to create an appimage for wings3d 2.2.4 x64.
I have made one on mx-18, and got it to work on mx-19 and bionicpup, but it wont work on mint, xubuntu-18.04.
I made it on mint-18, but it wont work on mint-19.2, xubuntu-18.04 or mx-18–19.
I made it on xubuntu-18-04 only woks on xubuntu-18.04.

I am not a dev of wings3d.
the dev has no time to create another package type, so i’m trying.
wings3d is based on erlang
I have no programming experience. I downloaded the deb files and dependencies and used the extracted bzip.run file to create the appdir with pkg2appdir.
some of my problems making this cross os seem to be due to erlang-wx.
WX Failed loading “wxe_driver”@"/tmp/.mount_wings3MjbwJT/lib/wx-1.8.7/priv"
can someone with experience making appimages give this a try, or help me figuring this out?
like i said i have no coding experience, i cant even figure out how to get stuff from the repos using yml.
this appimage creation process is a real eye opener for me.I think i have reach the limits of my understanding, but will try to learn more.

Thanks for any consideration.

the key was in the second error. added pakg for libjpg and libpng, and now it works on
mx-18, mx-19, bionicpup, mint-18, mint-19, xubuntu-18.04

wings3d_2.2.4_stretch-1.1_amd64-x86_64.AppImage

temp download link:

give this one a try I think it’s a winner.

tried with Linux Mint 19 but it doesn’t work:

=ERROR REPORT==== 23-Nov-2019::17:22:24.601514 ===
WX Failed loading “wxe_driver”@"/tmp/.mount_Wings39sgnjA/lib/wx-1.8.7/priv"

=CRASH REPORT==== 23-Nov-2019::17:22:24.641393 ===
crasher:
initial call: wxe_master:init/1
pid: <0.81.0>
registered_name: []
exception error: {load_driver,“libjpeg.so.62: cannot open shared object file: No such file or directory”}
in function wxe_master:init/1 (wxe_master.erl, line 132)
in call from gen_server:init_it/2 (gen_server.erl, line 374)
in call from gen_server:init_it/6 (gen_server.erl, line 342)
ancestors: [<0.80.0>,wings_sup,<0.78.0>]
message_queue_len: 0
messages: []
links: []
dictionary: []
trap_exit: false
status: running
heap_size: 987
stack_size: 27
reductions: 2926
neighbours:

1 Like

Now I need to figure out how to make it execute from the desktop file.
can not figure out how to make locations relative.
[Desktop Entry]
Type=Application
Terminal=false
Exec=/wings
Name=wings3d_2.2.4_amd64
GenericName=A 3D Subdivision Modeler
Comment=A 3D modeler that is both powerful and easy to use
GenericName[en]=A 3D Subdivision Modeler
Comment[en]=A 3D modeler that is both powerful and easy to use
Icon=wings3d
Categories=Graphics;3DGraphics;
Name[en_US.UTF-8]=wings3d.desktop

AppRun:
#!/bin/sh
HERE="(dirname "(readlink -f “{0}")")" export UNION_PRELOAD="{HERE}”
export LD_PRELOAD="{HERE}/libunionpreload.so" export PATH="{HERE}"/usr/bin/:"{HERE}"/usr/sbin/:"{HERE}"/usr/games/:"{HERE}"/bin/:"{HERE}"/sbin/:"{PATH}" export LD_LIBRARY_PATH="{HERE}"/usr/lib/:"{HERE}"/usr/lib/i386-linux-gnu/:"{HERE}"/usr/lib/x86_64-linux-gnu/:"{HERE}"/usr/lib32/:"{HERE}"/usr/lib64/:"{HERE}"/lib/:"{HERE}"/lib/i386-linux-gnu/:"{HERE}"/lib/x86_64-linux-gnu/:"{HERE}"/lib32/:"{HERE}"/lib64/:"{LD_LIBRARY_PATH}"
export PYTHONPATH="{HERE}"/usr/share/pyshared/:"{PYTHONPATH}"
export PYTHONHOME="{HERE}"/usr/ export XDG_DATA_DIRS="{HERE}"/usr/share/:"{XDG_DATA_DIRS}" export PERLLIB="{HERE}"/usr/share/perl5/:"{HERE}"/usr/lib/perl5/:"{PERLLIB}"
export GSETTINGS_SCHEMA_DIR="{HERE}"/usr/share/glib-2.0/schemas/:"{GSETTINGS_SCHEMA_DIR}"
export QT_PLUGIN_PATH="{HERE}"/usr/lib/qt4/plugins/:"{HERE}"/usr/lib/i386-linux-gnu/qt4/plugins/:"{HERE}"/usr/lib/x86_64-linux-gnu/qt4/plugins/:"{HERE}"/usr/lib32/qt4/plugins/:"{HERE}"/usr/lib64/qt4/plugins/:"{HERE}"/usr/lib/qt5/plugins/:"{HERE}"/usr/lib/i386-linux-gnu/qt5/plugins/:"{HERE}"/usr/lib/x86_64-linux-gnu/qt5/plugins/:"{HERE}"/usr/lib32/qt5/plugins/:"{HERE}"/usr/lib64/qt5/plugins/:"{QT_PLUGIN_PATH}" #EXEC=(grep -e ‘^Exec=.*’ "{HERE}"/*.desktop | head -n 1 | cut -d "=" -f 2- | sed -e 's|%.||g') #exec {EXEC} “@" exec "{HERE}”/wings

Can anyone help with getting opencl working from inside an appimage?

Hi, please ask the authors of Wings3d to provide an officially supported AppImage. Thanks! :+1:

1 Like