AppImage

/bin/sh: 2: convert: not found

hello!

I’m trying to make an appimage (using appimage-builder) of a python/qt script. All seems to work well except: In the script I call an external command ‘convert’ (imagemagick). It looks like the binary is in the AppDir/usr/bin directory, but still the shell reports it can’t find the file. I tried to use the full path to the file instead, with no luck. In python I use ‘subprocess’ to execute the command. I tried also to print the PATH environment variable from within python, that seems to include the correct path to ‘convert’…

Any suggestions on how to debug this further? Should I use appimage-builder at all, as it is an extra layer that maybe introduces difficulties…

Thnx!

Hello @josvanr. For Python, specific solutions exist:

But these are concerned with bundling Python applications, whereas convert is not a Python application. Bundling it requires additional work (it is its own application, after all).

For appimage-builder, please open an issue describing the details over at

Thank you!

ok thnx ! Yes, the python part works, after some tweaking. Ok I will do so !

@josvanr If you’re calling the command using something like "/bin/sh convert ", the execution flow goes out of the AppImage and the private environment is removed.

The solution is to also bundle the sh command, so the execution chain never leaves the AppImage environment.