AppImage

Image wont install steuid sandbox is not running as root

Hi there,

I’m trying to run the Github Desktop Linux fork .appimage version.

When I try to install it I get the following error,

  * An unprivileged process using ptrace on it, like a debugger.
  * A parent process set prctl(PR_SET_NO_NEW_PRIVS, ...)
Failed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted
Trace/breakpoint trap (core dumped)

Steps I have taken so far:

  • After googling setuid I have worked out that it is related with chrome and I have tried to run it as root but that haven’t worked
  • I have also tried sudo ./GitHubDesktop-Linux-2.5.0-linux1.AppImage
  • I have also tried to install it by double-clicking it with the graphical interface

Thank you

I’ve found the work around that wasn’t long.
sudo ./GitHubDesktop-Linux-2.5.0-linux1.AppImage --no-sandbox

The kernel on your distribution is configured in a way that prevents this from working properly. Maybe you want to discuss this issue with your Linux distribution.

So a solution is to run

sysctl kernel.unprivileged_userns_clone=1

then you won’t need the --no-sandbox.

1 Like